This is the community forum. For a developer response use the Client Area.
Follow us on Facebook, Twitter and YouTube!

Auto Pages (Outdated)

'Auto Pages' is the name of the add-on that I wrote today. It is my own version of Static's 'Arbitrary ID' add-on. At this moment, Auto Pages has the advantage that the administrator is able to specify exactly which URL parameter(s) are important to the page when automatically creating it. It can then remove any unwanted parameters. On the other hand if your page works without parameters then you can tell the add-on this and it will remove them if present. All of my basic tests have worked successfully. I now need to test it further, clean up the code and work on some documentation. The current aim is to release it by Wednesday 9th.

Have you completed the interview?

This add-on is now available for download:

Please note that it is at the moment considered experimental. This means that it hasn't yet received much feedback from being used in a live environment. As such, make sure to fully test the add-on first before deploying it.

Further information, including installation steps, can be found here:

Have you completed the interview?

installed but i think there is a folder path problem & in Comments: Enabled i disabled few things like website & country but still the option is can be seen.

wat will be the issue?

& thank you very much for releasing this

1. The path to your stylesheet inside your head tag is incorrect. As your page (PC.GAME_278981857.html) is in a directory (game-torrents) and not in the root of your website you will need to either add "../" to the beginning of the path or alternatively enter the full URL to it ( ). Take a look at the detailed integration guide on the wiki for more information.

2. Go to Layout -> Form -> Enabled to choose which options the form has.

Have you completed the interview?

3. Make sure you have the correct URL to your /comments/ folder in Settings -> System.

Have you completed the interview?

Comments URL:

<link rel="stylesheet" type="text/css" href=""/>



Options -Indexes +FollowSymLinks
RewriteEngine On
ErrorDocument 400 /404.php
ErrorDocument 401 /401.php
ErrorDocument 403 /403.php
ErrorDocument 404 /404.php
ErrorDocument 500 /500.php
RewriteCond %{SCRIPT_FILENAME} !-d
RewriteCond %{SCRIPT_FILENAME} !-f
RewriteRule ^tag/(.*)$ search.php?q=$1
RewriteRule ^google/(.*)$ google.php
RewriteRule help/(.*)$ help.php
RewriteRule ^all-torrents/latest/(.*)$ all.php?cat=$1
RewriteRule ^(.*)-torrents/(.*)/(.*)$/ search.php?cat=$1&orderby=$2&p=$3&browse=true [L]
RewriteRule ^(.*)-torrents/(.*)/(.*)$ search.php?cat=$1&orderby=$2&p=$3&browse=true [L]
RewriteRule ^(.*)-torrents$ search.php?cat=$1&orderby=2&browse=true [L]
RewriteRule ^(.*)-torrents/$ search.php?cat=$1&orderby=2&browse=true [L]
RewriteRule ^(.*)-torrents/(.*)_(.*).html$ detail.php?cat=$1&id=$3 [L]
RewriteRule ^rss/(.*)$ rss.php?cat=$1&browse=true&%{QUERY_STRING} [L]

Thanks for helping
also when i post comment i got redirected to this page here i can see the comment but when i browse the defualt link the comment was disappeared

please look into this

I quit!

HoiHoi Steven,

just installed an tested it a bit. No big problems, yet^^


AutoPages is not case-sensitive with auto-adresses!
f. e. -> the adress "testTEST.php" will be converted in "testtest.php" so the smilies and links (into sent mails) and other things are not working.
(the solution for the moment: Not to use uppercaseWink)

More feedback will follow!


P.S.: The german "Umlaute" (utf8-problem) are wrong - could you send me a list of all neccessary to-be-translated-sites of commentics, so I can do this job?
Btw. where can I take on/off the captcha/ things?

...sorry, can't edit my last postConfused

P.P.S.: The auto-site-registration from auto-post makes a different between the url-adresses --> "" and "", so the comments with/without "www." will not displayed both together...Sad

Hi Ming,

You can turn off the image and question captcha in Layout -> Form -> Enabled.

I don't understand what you mean about sending you a list of sites to be translated. Could you explain that again please?

It's strange that Auto Pages makes any distinction between a URL address with www and without www because I developed the add-on so that wouldn't be an issue. I think the best solution is to add some code to your website's root .htaccess file to force the use of one of the two ways (with www or without). This looks like a good tutorial for that:

Have you completed the interview?

Possibly Related Threads…
Thread / Author Replies Views Last Post
Last Post by Steven
19-Jun-2017, 08:04 PM
Last Post by kooler
02-Aug-2013, 05:29 PM
Last Post by Norbs
05-Dec-2011, 03:05 PM
Last Post by Static
20-Jan-2011, 01:55 AM
Last Post by Static
31-Dec-2010, 08:09 AM

Forum Jump:

Users browsing this thread: 1 Guest(s)