This is the community forum. For a developer response use the Client Area.
Follow us on Facebook, Twitter and YouTube!

Email notification does not work
#1

I'm not getting any confirmation e-mails for when a new comment is submitted and waiting for approval. I enabled error reporting and when i just now tried to post a test comment the page showed up with what's below as soon as I clicked the add comment button.
I seen this similar thread Email notification does not work
It shouldn't be able to detect me as admin as I posted in a virtual machine connected to a VPN.

It's not going in a spam folder and I'm getting subscribers listed under manage.







Fatal error: Uncaught exception 'Swift_TransportException' with message 'Expected response code 220 but got code "", with message ""' in /volume1/web/dantech/comments/includes/swift_mailer/lib/classes/Swift/Transport/AbstractSmtpTransport.php:422 Stack trace: #0 /volume1/web/dantech/comments/includes/swift_mailer/lib/classes/Swift/Transport/AbstractSmtpTransport.php(315): Swift_Transport_AbstractSmtpTransport->_assertResponseCode('', Array) #1 /volume1/web/dantech/comments/includes/swift_mailer/lib/classes/Swift/Transport/AbstractSmtpTransport.php(123): Swift_Transport_AbstractSmtpTransport->_readGreeting() #2 /volume1/web/dantech/comments/includes/swift_mailer/lib/classes/Swift/Transport/SendmailTransport.php(57): Swift_Transport_AbstractSmtpTransport->start() #3 /volume1/web/dantech/comments/includes/swift_mailer/lib/classes/Swift/Mailer.php(79): Swift_Transport_SendmailTransport->start() #4 /volume1/web/dantech/comments/includes/functions/processor.php(116): Swift_Mailer->send(Object(Swift_Message)) #5 /volume1/web/dan in /volume1/web/dantech/comments/includes/swift_mailer/lib/classes/Swift/Transport/AbstractSmtpTransport.php on line 422
Reply
#2

Hi,

Okay, so you're using the SMTP method. Are you sure you have the correct settings? For example, the encryption setting might need to be 'SSL' or the port number may be incorrect.

Have you completed the interview?
Reply
#3

If anyone else gets this error change to

Encrypt: TLS
Port: 587

It worked for me.
Reply


Possibly Related Threads…
Thread / Author Replies Views Last Post
Last Post by jemie
23-Oct-2015, 05:44 PM
Last Post by gano101
12-Nov-2014, 10:06 PM
Last Post by mariank
15-Dec-2013, 08:46 PM

Forum Jump:


Users browsing this thread: 1 Guest(s)