This is the community forum. For a developer response use the Client Area.
Follow us on Facebook, Twitter and YouTube!

Stuck on database details
#1

At the /install/ I am stuck on the database details: "There was a database connection error. No such file or directory (2002)."

Notes:

I am trying to upgrade from v2.5. I downloaded Commentics-3.4. 

For Database Name: I have xxxx_Commentics. I've tried the server which looks like db999x.example.com.

I know the password is correct as I was successful opening the db in phpMyAdmin.

I've tried 127.0.0.1 as Database Port.

I noticed the phpMyAdmin [/url]Server: :3306 »Database: xxxx_Commentics. Tried 3306 as Database Port, no luck.[url=https://my-db.pair.com/phpMyAdmin/db_structure.php?db=hotbst_Commentics]

Any suggestions would be appreciated.

~paul
Reply
#2

Hi Paul,

1. Try putting 127.0.0.1 as the host rather than the port.

2. There's a specific procedure for upgrading from v2.5 to v3.4. See more info here.

Have you completed the interview?
Reply
#3

Steve:

Thank you for the very quick response.

>> 1. Try putting 127.0.0.1 as the host rather than the port.
I misspoke (mistyped?) I tried 127.0.0.1. I meant to say that I tried 3306 as the database port.

I had seen the specific procedure for upgrading v2.5 to v3.4 and was following that.

So basically I started over again by deleting the old commentics files, installing the v3.0 files and then proceeded according to the https://www.commentics.org/forum/attachment.php?aid=334 instructions. Still I get "There was a database connection error. Connection refused (2002)." when I get to "9. Run the upgrade http://www.your-domain.com/upload/install/" in the upgrade.html file. I'm assuming that is a mysql error?

Thank you again for your help.

~paul
Reply
#4

OK, I was able to move on.

The solution: I entered "db999x.example.com", or something along those lines, into the Port field.

Now I see "Mcrypt extension is loaded" is a Fail. Will get to work on that one.

~Paul
Reply


Possibly Related Threads…
Thread / Author Replies Views Last Post
Last Post by Steven
28-Feb-2020, 09:20 PM
Last Post by bobby
21-Dec-2017, 03:33 AM

Forum Jump:


Users browsing this thread: 1 Guest(s)