This is the community forum. For a developer response use the Client Area.
Follow us on Facebook, Twitter and YouTube!

Upgrade email situation
#1

Hello:

I am currently upgrading from v2.5, using the upgrade.html listing. I am now installing the v3.0 upgrade.

I got to the admin panel but am unable to login with what I know to be the correct username and password; it worked before I attempted the upgrade.

When I click on "Lost Your Details?" the email address is rejected (Email address not found) yet it is the email I see in the admin table.

In looking at the admins table in the database using phpMyAdmin I see the IP address to be incorrect; it's from a former ISP account. Is this the problem?

How can I force a admin account reset?

Thank you for your support!

~Paul
Reply
#2

Hi Paul,

No your IP address wouldn't affect this. Try the solution in the following FAQ:

https://www.commentics.org/faq/general/reset-password

Have you completed the interview?
Reply
#3

Steve:

The password replacement worked.

Now getting through the other revisions.

Latest hangup: My (renamed) backend has "Error: Could not load email new_version!"

Many thanks for your help and patience.

~Paul
Reply
#4

OK, did some searching, found a thread that recommended I comment out the following line in task.php:

$this->notify->adminNotifyNewVersion(CMTX_VERSION, $latest_version);

I no longer get the "Error: Could not load email new_version!" message.

However, my admin page is blank at /index.php?page=dashboard, even when I add my trusty php error lines:

error_reporting(E_ALL);
ini_set('display_errors', TRUE);
ini_set('display_startup_errors', TRUE);



Any ideas?

~Paul
Reply
#5

Hi Paul,

Check your /system/logs/errors.log file. Also check your server's error logs.

Have you completed the interview?
Reply
#6

Steven:

I was able to successfully upgrade to v3.4 in that I completed the install and saw the login page which lead me to the admin page.

Am now trying to install to go to v4.0 via changed_files_34_40.

Did the /install/ all looked fine, was told "You already have the latest version". However I am unable to go beyond that. Aren't I supposed to see the admin login at that time?

Now trying the /backend/index.php (after renaming "backend") and only see a blank page.

errors.log has PHP Notice:  Undefined index: last_task in commentics/system/library/setting.php on line 22

I tried executing the SQL in https://www.commentics.org/forum/showthr...p?tid=1758

Server logs do not show any errors. Also including error_reporting(E_ALL); | ini_set('display_errors', TRUE); | ini_set('display_startup_errors', TRUE); in the index.php file does not show any errors.

Sorry to be such a pain and thank you for your support!

~paul
Reply
#7

Hi Paul,

Would you be able to PM me your site's FTP and admin login details? I think that's the only way I can help further with this.

Have you completed the interview?
Reply
#8

PM sent.

~Paul
Reply
#9

Hi Paul,

I had a look and it was because the only files on your site were the files from the 'changed files package'. All of the other files that make up Commentics weren't there. So I uploaded all of the missing files and it appears to work now. Don't worry about payment, just spread the word about the project.

Have you completed the interview?
Reply


Possibly Related Threads…
Thread / Author Replies Views Last Post
Last Post by ddraber
15-Apr-2019, 02:34 PM

Forum Jump:


Users browsing this thread: 1 Guest(s)