This is the community forum. For a developer response use the Client Area.
Follow us on Facebook, Twitter and YouTube!

Change comments date, another domain

Just purchased Commentics yesterday. Great comment script and thanks to everybody who made this possible. Have some questions. Did not find answer when searching.
1) Commentics is installed on How can I show the same form and same page on Now, form field shows “Error: No site found with the domain ''

2) I have dropped CMS and going for statics CSS/Flex box site. Have tens of comments on that CMS site. Want to add these comments manually in Commentics. Any easier methods to change comments dates in Commentics without going to the database. I have tried to export DB, editing and import. It works fine but that’s the hard way.

3) Commentics seems working slow in my case after clicking “Add Comment” button. I think at least for 5 seconds. May be this is too long to send about 5 lines of text comment. The form consists only comment. Name and Country field.

Hope someone is here to help.

Hi thanks for purchasing your licence. Hopefully the below answers help.

1) On you need to go to 'Manage -> Sites' and add
2) Changing the date of a comment requires going to the database.
3) Check to see if any errors are being generated. Do you have Akismet enabled? What's the link to your page? I might be able to determine what the reason is.

Have you completed the interview?

I've just added an FAQ for the above.

Have you completed the interview?

Quick answer. Thanks!
1) Works. Comment form appears on Existed comments from from the same page/article is not visible on If this is possible? Or may be I have to test it with a comment from after adding
2) OK. Good to know.
3) No error, no Akismet. Just noticed a delay. Site:

Is good to have 1) on FAQ.

Got the test comment. Haven't approved it since it is a test comment.
Thanks again.

Commentics isn't designed to load the same page on multiple websites. However you might be able to do it by making the following change. In /system/library/page.php:

Find this:
PHP Code:
$query $this->db->query("SELECT * FROM `" CMTX_DB_PREFIX "pages` WHERE `identifier` = '" $this->db->escape($identifier) . "' AND `site_id` = '" . (int) $site_id "'"); 

Replace with:
PHP Code:
$query $this->db->query("SELECT * FROM `" CMTX_DB_PREFIX "pages` WHERE `identifier` = '" $this->db->escape($identifier) . "'"); 

The reason that submitting a comment is taking so long is likely because your website is connecting to an SMTP server to send the email. The connection between your server and your SMTP server is probably slow.

Also your website's stylesheet is applying some unwanted styling to the images. Try adding this:

#cmtx_container img {
    float: none;
    margin: 0;
    padding: 0;
    border: 0;
    border-radius: 0;
    width: auto;

Have you completed the interview?

Changed opinion about having same comments on to domains with same page. Thanks for the suggestion!

The CSS:
I have added that and the user icon looks as intended. I have also removed own IMG borders and radius.

The delay:
If I don't want to receive email, may be it will be faster. Can check at least once a day in admin panel.
I have just started to add contents from the former CMC site, so there will not be many comments at this time any way.

The comment field expanded all the time?
How can I do this including only name and country (not name lists) field. I haven't searched for this answer in the forum and using shortcut here. I want these there fields clearly visible so the user knows what to expect to type on a blink.

If you go to 'Settings -> Administrator' you can turn off the individual emails that you receive.

In 'Settings -> Layout -> Form' if you click the 'here' link at the top there should be a setting called 'Hide'. Disabling that should display all the fields straight away.

Have you completed the interview?

I was wondering if it is possible to see the comment field box extended the same size all the time (before/during/after) the user is typing. During can be different depending how much the user types.

The interview: Done.
Pleasant day.

Thanks for submitting the interview. I'll publish it in the next few days.

In /frontend/view/default/template/main/form.tpl

Remove all instances of this:
{{ cmtx_wait_for_comment }}

Then find this:
class="cmtx_field cmtx_textarea_field cmtx_comment_field {{ comment_symbol }}"

Change to:
class="cmtx_field cmtx_textarea_field cmtx_comment_field cmtx_comment_field_active {{ comment_symbol }}"

Have you completed the interview?

Possibly Related Threads…
Thread / Author Replies Views Last Post
Last Post by Steven
29-Jul-2020, 08:34 AM
Last Post by MattyP
13-Apr-2020, 08:33 PM

Forum Jump:

Users browsing this thread: 1 Guest(s)