This is the community forum. For a developer response use the Client Area.
Follow us on Facebook, Twitter and YouTube!

Link on comments page?

The links you sent me via PM go to a 'Not Found' page. Anyway it seems like you're blocked by your server. So you'll need to talk to your host.

Have you completed the interview?

I can't get up with them. They are all on lockdown because of the virus. I can do everything else on my server, I can log into Plesk, I can FTP, everything but comment on the page. I'm confused LOL

You mentioned Mod Security in an earlier reply. I checked my server logs. According to the online help I can turn it on and off in Plesk I just can't figure out how.

OK I have narrowed it down. It works in all browsers, unless I try to upload an image. That's when the button shades out, comes back and nothing. If I remove the image, or do not add an image at all then it will add the comment. Same thing on the page itself and the comment success link that comes in the email. And before this, it said "Admin" under the gravatar but it doesn't now. I can comment, just can't upload.

In DevTools the 403 error in the console tab is:

POST **********/frontend/index.php?route=main/form/submit 403

In the network tab, it's inde.php?route=main/form/submit 403 xhr

I can do everything except upload an image. But everyone else has been able to upload.

Maybe your server doesn't like the size of the image or something else about it. Try a few images to compare.

Have you completed the interview?

(13-Apr-2020, 05:11 PM)Steven Wrote:  Maybe your server doesn't like the size of the image or something else about it. Try a few images to compare.

I think I got it figured out.

My phone is my hotspot for my laptop and tablet, with a dynamic IP. If it doesn't post the comment, I have to reboot the phone to retrieve a new IP address. I cleared all data and cookies from Firefox and Chrome, rebooted laptop and phone, now it works and I can upload an image. However I discovered that if I go to the page in Firefox (default browser) I can post under MattyP but it says "new" under the gravatar. Same in Firefox and Chrome. If I open another tab in Firefox and log into the admin panel, and then post a comment while logged in, it will say "admin" under the gravatar. I'm not sure what the server is detecting but if it doesn't post the comment I have to reboot my phone to get a new IP. I've got brain overload LOL

I'm still not sure what exactly the server didn't like. I was testing the page with 3 devices, 3 different browsers, sometimes in the admin panel sometimes not. Somehow the dynamic IP address came into play I'm sure. If I want to reply or comment as admin I have to be logged into the admin panel in one tab and on the page in another tab in Firefox. Probably won't use Chrome for it anyway. Easily managed. but it is fixed it is working and I'm happy. I upgraded to the Premium version. Thank you for all your help and thank you for a fine product. Cool

Possibly Related Threads…
Thread / Author Replies Views Last Post
Last Post by Steven
29-Jul-2020, 08:34 AM
Last Post by Steven
04-Jul-2020, 06:46 PM

Forum Jump:

Users browsing this thread: 1 Guest(s)